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Title: Disk ID is missing during registration
Topic ID: 337 Link to this page
Category: Licensing
Modified: 2024-04-19 Created: 2005-08-24

SYMPTOM:

Disk ID field is missing during registration and therefore registration fails.

CAUSE:

Some computers are configured with the main drive not being letter C. C may be vacant or being used for card reader or Zip-drive. The problem should be fixed in more recent versions of Carlson products, but may prevent re-registration of older ones.

WORKAROUND:

  1. Open "My Computer" / Check to see if there is a drive labeled C:\. If you don't see any Drives labeled "C:" - skip to Step #2. To make Drive Letter "C:" available if it is already assigned follow steps a thru d:
    1. Go to Control Panel / Administrative Tools / Computer Management
    2. Click on Disk Management listed under Storage / Find current (C:) drive listed to the right
    3. Right-Click (C:) and select "Change Drive Letter" / Left click "C:" / Click the "Change" button
    4. Choose a different letter other than C from the list / click OK / click OK / exit out of Computer Mgmt. window
  2. Open Notepad and type the following line:

    subst c: X:\

    replace X with actual letter of your main hard drive. Save the file in easy to find location, like the root of your hard drive, under file name 'mysubst.bat' - make sure that this extension is saved.

  3. Click Start / All Programs / Find the folder called Startup and right-click on the Startup Folder / left-click Open.
  4. In that Startup folder, right-click / click New / click Shortcut / click Browse and pick mysubst.bat that we created in Step #3 / click Next / Click Finish / Exit out of the Startup Folder
  5. Now Reboot the system. After reboot there will be a C drive which is a link to your existing drive letter.

Registration should now work.

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